Current Recommended Versions

Note on Log4J CVE-2021-44228: We have updated the provided Docker images to include the bug fixes from Apache Solr, please update. Alternatively, please follow Apache Solr's instructions for securing ("Apache Solr affected by Apache Log4J CVE-2021-44228").

If you are still using EXT:solr 9, please update to the new version 9.0.3 and Apache Solr version 7.7. As an alternative, if this is not possible, please follow Apache Solr's instructions.

TYPO3 9.5 TYPO3 10.4 TYPO3 11.5
EXT:solr 11.0.5 11.2.0 11.5.0
Apache Solr 8.5 8.11 8.11
Configset ext_solr_11_0_0 ext_solr_11_2_0 ext_solr_11_5_0
PHP 7.2+ 7.2+ 7.4+
EXT:solrfal 8.0.1 10.0.0 11.0.0
EXT:solrconsole 4.0.1 10.0.0 11.0.0
EXT:debugtools 1.1.2 10.0.0 11.0.0-rc-1*
EXT:tika 6.0.2 10.0.2 11.0.0

(* We are currently working on the compatibility to TYPO3 11 LTS, you'll be able to download the applicable versions from here as soon as available, release candidates for TYPO3 11.5. are already available)


A more detailed version of this version matrix can be found in the documentation of EXT:solr.

The current versions of our Solr add-ons are only available for members of the funding contribution program and can be found in the add-on section.